TI中文支持网
TI专业的中文技术问题咨询交流网站

自己打样的28069M+8305驱动板不明原因烧毁

自己打样的驱动板,与原版改动如下:

1、将28069M和DRV8305放置到同一块PCB上;

2、3.3V芯片替换为AMS1117-3.3;

目前未查明原因现状:

问题一:不连接电机使用lab02c测试,pwm信号输出正常,连接电机(T-Motor MN501)做参数识别时电流异常,不限流会导致DRV8305烧毁;

问题二:程序正常运行,28069M没有PWM输出;

PCB截图:

Green Deng:

1、有没有检测过DRV烧毁是因为过流的原因还是因为接上电机后某引脚短路引起的烧毁?
2、问题一&二的测试条件不一样吗?为什么“一”可以发出PWM波而“二”不可以?跑过例程测试吗?

user1913824:

回复 Green Deng:

1、已经多次测试,信号正常,未出现短路; 2、问题二主要出现在DRV8305烧毁之后,更换新的芯片,输出不正常,这一点有可能是焊接问题或者引脚烧毁,并且是3相pwm都没有输出,不知道会不会出现pwm端口烧毁的现象?

下面是DRV8305烧毁了后更换后,28069识别错误,无法下载,调试器通信测试时ok的

补充:原来的DRV8305的评估板上是两个330uF的铝解电容,目前我自己的板子用的是一个120uF的,不知道这个影响大不大。

Green Deng:

回复 user1913824:

你是测试的DRV的输出还是芯片的输出?如果3相都没有输出的话可能是整块芯片的问题了
报错问题似乎是因为复位引起的,你测试一下芯片复位引脚是不是一直有复位的低电平信号?

user1913824:

回复 Green Deng:

这个是不插电机时用lab02c测试,DRV8305达到了73度,插上电机的话温度更高,PCB是4层镀金板,焊接良好,背面无元器件

Green Deng:

回复 user1913824:

这个温度似乎是偏高的,我这边运行lab05b,温度应该在40℃左右。有检查过各个电源引脚的对地电压吗?
另外,你是在flash运行的?因为你说过芯片无法下载程序

user1913824:

回复 Green Deng:

电源引脚对地电压都在数据手册范围之内,我这边有多块样板,程序在RAM运行的,分开供电测试,不下载程序的情况下(DSP不运行)3.3V电源电流0.04A,24V电源无电流,28069温度正常,DRV8305温度53度左右,明显过温,运行lab02c就会到70+

Green Deng:

回复 user1913824:

我这边看下来,更偏向于F28069工作正常,但DRV8305不正常,从而也可能影响到了MCU的运行。
有没有可能硬件上将两块芯片断开单独测试F28069?同时F28069建议用例程跑一下,看各方面输出是否正常。
F28069的PWM例程可以在以下路径找到:C:\ti\c2000\C2000Ware_2_00_00_03\device_support\f2806x\examples\c28

user1913824:

回复 Green Deng:

历史问题:

1、8305发热应该是扇热没处理好,表层覆铜面积太小;

2、PWM无输出问题还是未能解决,GPIO控制的LED正常在闪烁,PWM无输出;

新增问题:

下载其他板子没问题,有一块板锁住了,之前类似情况都是换芯片,论坛里面也没有看到明确的解锁办法,这种情况能不能软件解除锁定?

赞(0)
未经允许不得转载:TI中文支持网 » 自己打样的28069M+8305驱动板不明原因烧毁
分享到: 更多 (0)