TI中文支持网
TI专业的中文技术问题咨询交流网站

INA333: 输出一直是高电压

Part Number:INA333

您好,我将一个压力传感器接ina333,RG的为100R(增益为1001),5V的供电,如图,左侧接插件接一个压力传感器

问题:1、VIN+和VIN-用万用表测量一个是3V一个是1.5V,没压力时不是应该一样吗?

2、输出一直是个稳定的5V,没有变化。

压力大概是0.2mV

Amy Luo:

您好,

1、

ping JIN 说:1、VIN+和VIN-用万用表测量一个是3V一个是1.5V,没压力时不是应该一样吗?

INA333输出电压是Vout = G* (VIN+ – VIN- )+VREF;  VIN+和VIN-一个是3V一个是1.5V,而增益为1001,输出肯定饱和了,为电源电压。

您这里说“没压力时不是应该一样吗”,具体是什么意思,您可以详细说明吗?

2、

ping JIN 说:输出一直是个稳定的5V,没有变化。

这里测量的INA333的输入管脚(VIN+ 、 VIN- )处的电压是多少?可根据Vout = G* (VIN+ – VIN- )+VREF这个公式计算输出电压

,

ping JIN:

谢谢您的回答!

您帮看下图画的对吗?

1、INA333前面接的是一个压力传感器,测量的VIN+和VIN-的值不一样是什么原因哪?

2、这个仪表放大器容易成为比较器吗?

,

Amy Luo:

对于INA333模拟输入管脚,建议去掉C2和C3;

ping JIN 说:1、INA333前面接的是一个压力传感器,测量的VIN+和VIN-的值不一样是什么原因哪?

压力传感器断开与INA333的连接,传感器输出正确吗?

ping JIN 说:2、这个仪表放大器容易成为比较器吗?

不能成为比较器,因为其内部是由3个运放构成,输出端的运放A3是差分电路,不会构成正反馈;但是如果输入不满足仪表运放的输入范围,输出就会饱和输出,即输出会趋于电源电压或0V

,

ping JIN:

您好,计算的压力传感器对仪表放大器VIN+和VIN-的电压是3V左右,上面提供的电路图中没有焊接C2和C3。用5V电源供电时会将其电压拉低,如下图,当设置的电流为20mA时,电压拉低到了1.8V;如果设置的电流为30mA时拉低到了2.3V;10mA时1.2V。

问题:1、根据上面描述,电压为什么会被拉低哪,具体拉低的原因会是什么?

2、根据上面图中的值,示波器量输出端,有时会出现一会儿是高饱和电平,一会儿是0,有时会是一个1.5V左右的电压,能帮分析下吗?输入范围只有输入电压的要求吗,是VCM的范围为(V-)+0.1~(V+)-0.1这个指标吗,我设置的值应该是在范围内啊?别的还可能是哪个参数会超范围哪

3、上面相同的电路,昨天晚上测试,设置的5V/20mA的供电,电压被拉低到差不多2.8V,输出端可以测出VIN+和VIN-不同输入产生的波动,如下图;但今天再打开设备相同的设置,电压就被拉低到1.8V了,输出也测试不到信号

问题有些多,辛苦给回复下,谢谢!

,

Amy Luo:

压力传感器断开与INA333的连接,传感器输出正确吗?

INA333输入其他已知信号,输出正常吗?

,

ping JIN:

传感器的输出是正确的。刚刚测试发现RG电阻(目前用的是100欧姆1%的精度)重新更换一个时,刚更换完电压是2.7V,可以检测有信号输出,但电压会慢慢的往下降,会从2.7V降到1.8V基本就不怎么降了,到1.8V时就检测不到信号了,之后重新断电再上电就直接是1.8V了,也检测不到信号。重新更换电阻就出现相同的情况,不清楚为什么电压会一直往下降

,

Amy Luo:

您的意思是VCC_5V供电电压会被拉低?提供不同的供电电流,拉低的电压不同?

VREF通过两个100Ω电阻分压电路,这里就消耗5/200=25mA,传感器需求电流多少?有没有可能是VCC_5V提供的总电流不够造成的?

另外在使用电阻分压产生VREF时,建议使用电压跟随器隔离一下VREF;

测试时,INA333输出端是否断开了后级电路?断开后级电路看是怎样?以排除后级电路的影响

,

ping JIN:

是的,5V会被拉低;不同的供电电流拉低的电压不同。

增大电流应该是会饱和,因为增大电流只有一个高压,检测不到信号。

可以测到信号的情况只有在刚更换了RG电阻之后,20mA的电流,电压从2.7V降到1.9V之间时可以检测到信号。

INA333后级没有接其它电路,输出端直接接的示波器。

,

Amy Luo:

测试时,传感器的输出是多少?您可以附上示波器同时测量传感器输出信号和INA333的输出信号吗?

,

ping JIN:

传感器两个信号的输出端是1.1V,INA333的输出差不多是1.2V

,

Amy Luo:

ping JIN 说:传感器两个信号的输出端是1.1V,INA333的输出差不多是1.2V

这个输出是正常的吗?

ping JIN 说:增大电流应该是会饱和,因为增大电流只有一个高压,检测不到信号。

增大供电电流时,传感器输出正常吗?您可以给出这种情况下的INA333输入和输出波形吗?

,

ping JIN:

如下图黄色为INA333的输入端,蓝色为输出端,四个图分别是20mA、30mA、 50mA、100mA供电电流时测的,供电电压都是5V。示波器每格都是500mV

… ………

,

Amy Luo:

图片没有显示,您可以再重新上传吗

,

ping JIN:

您好,不知道是不是网速慢的原因,图片一直传不上。测试结果描述如下:

输入5V、20mA时,电压被拉低到1.67V,INA333输入端不到500mV,输出将近1.5V;

输入5V、30mA时,电压被拉低到2.16V,INA333输入端差不多500mV,输出1.5V多点;

输入5V、50mA时,电压被拉低到3V,INA333输入端500mV多,不到1V,输出将近2V多,不到2.5V;

输入5V、0.1A时,电压被拉低到4.5V,INA333输入端和输出都是很大的杂波

,

Amy Luo:

供电电压VCC_5V除了给上述图片中电路供电外,还有其他负载吗?

INA333输入端电压约500mV,设置1001倍的增益,运放输出饱和才对,输出1.5V或2V是异常的;

您测试了几块电路板是这种情况?您可以多测试几块电路板吗

,

ping JIN:

还给压力传感器供电,压力传感器的供电范围是3-15V,其它没有了,INA333后面也没有负载。焊了两块电路板测试都不好。现在测试即使电压在2.7V,输出也只是个1.2V的电压,按压传感器,输出也没有反应了。好郁闷。。。

,

Amy Luo:

INA333芯片是正常的吗?您可以断开传感器的连接,对INA333输入已知直流信号,INA333能正常输出吗

,

ping JIN:

您的意思是INA333的VIN+和VIN-分别输入相差几毫伏的直流吗?

按原理图所示重新焊接一块电路板,不焊C2和C3,上电后电压是3.9V左右,可以测到信号输出。但过一会儿就会出现很多杂波,电压有时也会变到2点几伏,断电重新上电就是2点几伏了,有时有杂波有时没有,但都测不到信号了。

您帮看下我电路图是缺什么东西吗,总是会拉低电压,而且不稳定。在R6上并一个100nF的电容没有改变,传感器和INA333分开供电也没有改变。

辛苦您了!

,

ping JIN:

第一个图是刚焊接好的电路板测试的波形,第二个和第三个图是过了一会之后的波形,电压有时维持在4V有时就变为3V多或者是2V多

,

Amy Luo:

电路图没看出问题

ping JIN 说:您的意思是INA333的VIN+和VIN-分别输入相差几毫伏的直流吗?

是的,您可以先测试一下吗?如果信号源不易设定,您可以调节RG值以设置合适的输出信号

赞(0)
未经允许不得转载:TI中文支持网 » INA333: 输出一直是高电压
分享到: 更多 (0)