TI中文支持网
TI专业的中文技术问题咨询交流网站

投影不同bit位图像时,曝光和周期的设置问题

DLP的曝光和周期有两种设置模式,一种是周期与曝光相等,另外一种是周期大于曝光230微秒以上。在这两种模型下,发现几个有问题的地方:

1. 当周期与曝光时间相等时

投影完图像后,DLP投影状态会停留在投影状态,需要重新校验LUT后,DLP才会变为停止状态,不知道这个是不是bug?

2. 当投影1bit图像时

如果配置周期与曝光时间相等时,会导致当前图像残留后一张投影的图像(每次投影都设置的清除DMD)。如果配置周期大于曝光时间,效果会得到改善,当大于某个值时,则不会有后一张投影的残留。不知道是什么原因?

3.当投影8bit图像时

如果总bit数不超过48bit,则两种周期与曝光配置方式都能正常投影。如果总bit数大于48bit(曝光时间设置能保证图像加载时间),使用周期与曝光时间相等的配置是可以正常投影的。如果周期大于曝光时间,这会出现buffer switch异常情况。比如序列为按顺序分配投影0x5,0x6,0x7三张图,如果使用LightCrafter分配投影每个图像的8bit,抓拍到的图像是正确的。但一直投影整个序列,这抓拍到的图像为0x5,0x6,0x5,不知道是怎么回事?

Kevin Shi:

您好!

感谢使用TI的DLP产品。

 请问是在使用TI的DLP4500EVM吗?如果是请问使用的GUI和固件是什么版本的?请更新到最新的版本。

针对您碰到的问题,请问是否可以给出详细的配置?我可以在TI的EVM上测试,看是否能够复现相同的问题。

Best regards

user6379505:

回复 Kevin Shi:

感谢Kevin Shi的答复。下载最新的4.4固件测试后,问题状态如下:
1. 问题1仍然存在
复现步骤为,随便添加一个pattern,单次投影。
1)将曝光时间和周期设置为相等,投影后,LightCrafter界面上Seq. Runing状态灯一直为绿色。点击Validate Sequence按钮后,Seq. Runing状态灯变为灰色;
2)将曝光时间和周期设置为相差大于230微米,投影后,LightCrafter界面上Seq. Runing状态灯自动变为灰色。

2. 问题2仍然存在
随便加载一张格雷码图片,将Sequence设为固定周期,并将投影过程中将相机抓拍到的图像保存下来。
1)将曝光和周期设置位相同值时,从第n(n从高位开始算)位图片上可以看到第n+1位格雷码的图像。n越大效果越明显;
2)将曝光和周期设置位差值大于230微米,格雷码重叠现象减弱,当差值到500微米时,重叠现象消失。

3. 问题3解决。

Kevin Shi:

回复 user6379505:

您好!

感谢分享。

针对问题1,的确会存在缩描述的情况,但是投影是正常的,并不影响其正常功能。

针对问题2,请问相机和投影是如何同步的?请使用Trigger信号同步,并且确保,每次相机的曝光都能包含该pattern的所有曝光时间。

Best regards

user6379505:

回复 Kevin Shi:

问题1的投影虽然正常,但是会导致业务流程出现问题。投影一直处于Running状态会导致获取投影的状态一直返回2,而且无法通过DLPC350_PatternDisplay接口强制变为0,只能通过每次投影完成后再做一次Validate Sequence操作,无形中增加了单次投影的耗时,影响了成像的帧率。

问题2用的是Trigger Out 1触发相机,相机的曝光和投影的曝光配置时长是一样的。

Kevin Shi:

回复 user6379505:

您好!
问题1,我需要和团队再确认下,然后回复给您。
问题2,从描述看很像投影和相机不同步的,相机也是处于触发模式吗?如果是Free run也会有重叠的情况。
Best regards

user6379505:

回复 Kevin Shi:

相机也是触发模式。投影的triger out 延时都用的默认值0微秒。

赞(0)
未经允许不得转载:TI中文支持网 » 投影不同bit位图像时,曝光和周期的设置问题
分享到: 更多 (0)